Problem on /usr/lib64/libxml2.so.2

cPanel plugin for php selection
Post Reply
halimzhz
Posts: 0
Joined: Wed Sep 02, 2015 5:09 pm

Problem on /usr/lib64/libxml2.so.2

Post by halimzhz »

Dear Nixtree,

I'm facing an error when i switch one of domain to PHP 5.3, my default PHP is 5.4, i found on Apache error log is:

[Mon Nov 02 19:19:19 2015] [error] [client xxx.xxx.xxx.xxx] /opt/ntphp/php53/bin/php-cgi: /usr/lib64/libxml2.so.2: no version information available (required by /opt/xslt/lib/libxslt.so.1)

I try to rename /opt/xml2 to /opt/xml2_old and i run /scripts/easyapache, and after that i run 'sh ntphpselector_manage.sh recompile 3' seem the problem on PHP 5.4 its solve with libxml but its doesnt solve with ntphpselector, how can i solve that ?

Please help. TQ



steve
Site Admin
Posts: 5
Joined: Tue Mar 10, 2015 12:41 am
Contact:

Re: Problem on /usr/lib64/libxml2.so.2

Post by steve »

Hello Halimzhz,

Can you please let me know the following details.

OS Version :
Default PHP version :

Once you have replied, I will pass this to the development team for check the issue and will update you in this forum.


-
Steve N
Support Staff
Nixtree Solutions LLP
cPanel Server management | Managed Backup Solutions | Outsourced Web Hosting support

halimzhz
Posts: 0
Joined: Wed Sep 02, 2015 5:09 pm

Re: Problem on /usr/lib64/libxml2.so.2

Post by halimzhz »

Dear Sir,

My Default PHP version is 5.4.45 and OS is CentOs 5.10

TQ



steve
Site Admin
Posts: 5
Joined: Tue Mar 10, 2015 12:41 am
Contact:

Re: Problem on /usr/lib64/libxml2.so.2

Post by steve »

Hello,

Can you please add a phpinfo page and check whether "libXML support" is active or not. Also make sure it is enabled in the default version.


-
Steve N
Support Staff
Nixtree Solutions LLP
cPanel Server management | Managed Backup Solutions | Outsourced Web Hosting support

Post Reply